Multiple Regions - Data Service - Outage

Incident Report for UiPath

Postmortem

Customer Impact

On March 31st 2026, 4:50 AM to 8:50 AM UTC, a small subset of customers experienced HTTP 500 errors when using the Data Service Entity Query API in multiple regions.

The issue occurred only for requests containing a user-defined filter configuration when the API is used directly, distinguishing it from filters generated by platform consumption surfaces (e.g., Activities).

For affected customers, queries with this specific payload request failed, while all other requests continued to function normally. No data loss or data inconsistency occurred.

Root Cause

The issue was triggered for a subset of requests with a specific payload pattern ("filterGroups": [null]) that was valid but not handled correctly by the system.

A recently introduced logging component did not properly handle this input. As a result, it failed during processing and caused the API to return an HTTP 500 error.

This exposed a gap in how the system handles certain uncommon but valid inputs. Additionally, because this logging runs as part of the request flow, its failure impacted the overall request instead of being isolated.

Detection

The issue was initially identified through an automated Sev2 alert and was also reported by a customer.

During the investigation, the engineering team identified a common payload pattern across failing requests and traced the issue to the query analytics telemetry path.

Response

Upon detection, the team identified the affected execution path and applied mitigation by disabling the related functionality via a configuration change.

This action immediately stopped the errors and restored normal API behavior. The issue was mitigated within 30 minutes.

Follow-Up

The following actions are being taken to prevent a recurrence:

  • Add safeguards to ensure logging code paths do not affect request execution
  • Aligning and tightening the Document to have the right payloads; then add API-level validation to reject semantically invalid filter structures with 4xx responses.
  • Add a test case to validate this exact failing scenario is now handled correctly
Posted Apr 02, 2026 - 08:11 UTC

Resolved

The issue is fixed and service is healthy.
Posted Mar 31, 2026 - 10:09 UTC

Monitoring

Team has rolled out the fix and currently monitoring the service health.
Posted Mar 31, 2026 - 09:03 UTC

Investigating

We are currently experiencing an outage affecting UiPath Data Service across multiple regions. Our engineering team is actively investigating the root cause and working to restore full functionality as quickly as possible.
Posted Mar 31, 2026 - 08:42 UTC
This incident affected: European Union (Data Service), United States (Data Service), Japan (Data Service), India (Data Service), Singapore (Data Service), Australia (Data Service), Canada (Data Service), UK (Data Service), and Switzerland (Data Service).