Multiple Regions - Integration Service - Partial Outage

Incident Report for UiPath

Resolved

The issue has been resolved. The system has remained stable during the monitoring period.
Posted Mar 20, 2026 - 07:57 UTC

Monitoring

A fix has been deployed and the service is recovering.
Current status: We are monitoring the system to ensure stability and full recovery. Further updates will be shared soon
Posted Mar 20, 2026 - 07:42 UTC

Update

We are currently investigating reports of an issue in Integration Service in multiple regions.

Impact: Integration Service existing connections are not visible in Orchestrator, and attempts to create a new connection result in no response

Our teams are actively working to identify the cause and assess the scope of the issue. Further updates will be shared as soon as more information becomes available.
Posted Mar 20, 2026 - 07:29 UTC

Investigating

We are currently investigating reports of an issue in Integration Service in Singapore region.

Impact: Integration Service existing connections are not visible in Orchestrator, and attempts to create a new connection result in no response

Our teams are actively working to identify the cause and assess the scope of the issue. Further updates will be shared as soon as more information becomes available.
Posted Mar 20, 2026 - 07:28 UTC
This incident affected: European Union (Integration Service), Singapore (Integration Service), and Canada (Integration Service).